The core reason is that the Gains API socket connection did not complete within the default 10 second timeout limit. The issue was detected by automated dead-letter alarms. This is the same core reason we had in the last incident from March 24th. We will extend the existing retry logic in the Gains client to mitigate network glitches over longer periods of time. This work is tracked in Jira ticket INT-353.
Posted Apr 28, 2025 - 08:31 CEST
Resolved
All orders have been resent. This incident is now resolved.
Posted Apr 28, 2025 - 08:03 CEST
Monitoring
The core reason is that the Gains API did not complete HTTP requests at the required rate.
Posted Apr 28, 2025 - 07:53 CEST
Identified
The incident affected 8337 sales order from UK. No other types or markets where affected. These sales orders have been now been resent successfully to Gains.
Posted Apr 28, 2025 - 07:49 CEST
Investigating
The data run on Sunday night did not successfully send all data to Gains. 8337 items has been rejected. We are investigating the root cause and preparing to resend the data.
Posted Apr 28, 2025 - 07:40 CEST
This incident affected: Cary Group - Gains integration.