Item locations from UK erratically rejected

Incident Report for Cary Group AB - Statuspage

Postmortem

The root cause is a change to the domain model, made in preparation for future ERP and pricing work. We introduced overly strict input validation for category values. The validation rules did not account for special characters present in UK item-location data, causing valid records to be rejected and downstream processing to be disrupted.

Input validation has been relaxed, and automated tests that verify validation against these specific UK item-location values have been added.

We apologize for this incident and its impact.

Posted Aug 26, 2025 - 09:58 CEST

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 09:57 CEST

Monitoring

A fix has been deployed to production. We are monitoring the situation.
Posted Aug 26, 2025 - 08:56 CEST

Update

We are continuing to work on a fix for this issue.
Posted Aug 26, 2025 - 08:29 CEST

Identified

The root problem is added input validation that is too strict. We are implementing a fix.
Posted Aug 26, 2025 - 08:17 CEST

Investigating

The integration platform erratically rejected item-locations for UK in the nightly run August 25th. Investigation is ongoing. This means that no SKU Locations was sent to Gains last night.

This affects only data from UK. No other market is affected.
Posted Aug 26, 2025 - 08:03 CEST
This incident affected: Cary Group - Integration platform.