The retry logic works, but the Gains API still timed out after a series of retries. Since the problem was in effect for four (4) minutes, we estimate that we cannot make the current retry any more aggressive since it would just increase the load on the Gains API.
We have notified the Gains team about this incident.
Posted May 13, 2025 - 08:42 CEST
Resolved
This incident is now resolved. See upcoming root cause analysis for more details.
This incident was of the same type as the one from April 28th.
The core reason is that the Gains API did not complete HTTP requests at the required rate.
Posted May 13, 2025 - 08:10 CEST
Identified
The incident affected 7575 sales order from UK. No other types or markets where affected. These sales orders have been now been resent successfully to Gains.
Posted May 13, 2025 - 08:10 CEST
Investigating
The data run on Sunday night did not successfully send all data to Gains. 7575 items has been rejected. We are investigating the root cause and preparing to resend the data.
Posted May 13, 2025 - 07:54 CEST
This incident affected: Cary Group - Gains integration.