The Gains API times out after a series of retries. We estimate that we cannot make the current retry logic any more aggressive since it would just increase the load on the Gains API.
We have notified the Gains team about this incident.
Posted Jun 20, 2025 - 07:52 CEST
Resolved
The incident affected 13 625 sales order from UK. No other types or markets where affected. These sales orders have been now been resent successfully to Gains.
This incident is now resolved.
Posted Jun 20, 2025 - 07:45 CEST
Identified
The core reason is that the Gains API did not complete HTTP requests at the required rate. We are resending data now.
Posted Jun 20, 2025 - 07:30 CEST
Investigating
The data run on Thursday night did not successfully send all data to Gains. 13 625 items has been rejected. We are investigating the root cause and preparing to resend the data.
Posted Jun 20, 2025 - 07:24 CEST
This incident affected: Cary Group - Gains integration.